Introduction
Unauthorized access to enterprise voice communications and sensitive call records can have immediate operational and privacy consequences. CVE-2025-58692 is a single flaw in Fortinet FortiVoice that lets attackers manipulate backend databases and potentially escalate privileges. The attack requires authentication, but that does not stop it.
About Fortinet and FortiVoice: Fortinet is a major global cybersecurity vendor whose products include FortiGate firewalls, FortiWeb, FortiMail, and FortiVoice. FortiVoice is Fortinet's unified communications platform for voice, conferencing, and messaging, and it is widely deployed in enterprise and critical infrastructure environments. Thousands of organizations worldwide use Fortinet products, so vulnerabilities in them matter to the broader tech industry.
Technical Information
CVE-2025-58692 is an improper neutralization of special elements used in an SQL command (CWE-89) affecting FortiVoice versions 7.2.0 through 7.2.2 and 7.0.0 through 7.0.7. It comes from insufficient input sanitization in certain HTTP or HTTPS endpoints. An authenticated attacker can inject malicious SQL statements by sending crafted requests to the FortiVoice web interface or API. The backend database reads the injected elements as part of the SQL logic and runs queries or commands the attacker should not be able to run.
The attack requires valid credentials. Once authenticated, an attacker can target vulnerable parameters in HTTP requests. Public advisories do not name the specific injection points, but the root cause is user input concatenated directly into SQL queries without adequate parameterization or escaping. Depending on the database configuration and permissions, this can lead to data exfiltration, modification of call records, privilege escalation, or in some cases remote code execution.
Fortinet fixed the vulnerability in FortiVoice 7.2.3, whose official release notes list fixes for multiple SQL injection issues. The fixes likely involve better input validation and parameterized queries.
Affected Systems and Versions
- FortiVoice 7.2.0 through 7.2.2
- FortiVoice 7.0.0 through 7.0.7
Every configuration of these versions is vulnerable if authenticated users can reach it. FortiVoice 7.2.3 and later resolve the vulnerability.
Vendor Security History
Fortinet has had multiple critical vulnerabilities across its product lines in recent years, including:
- CVE-2025-25257: Unauthenticated SQL injection in FortiWeb, exploited in the wild within days of disclosure.
- CVE-2025-32756: Stack-based buffer overflow in FortiVoice and other products, confirmed exploited in the wild.
- CVE-2023-48788: Critical SQL injection in FortiClientEMS, also exploited in the wild.
The number of severe vulnerabilities suggests ongoing problems with secure development and code review. Fortinet does typically release advisories and patches promptly after discovery.



